Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 01, 2025 - 14:00 UTC
Scheduled
ServLogi will be conducting scheduled network maintenance at our Buffalo facility beginning at 7:00 A.M. Eastern Time. This maintenance involves a software upgrade to our edge router infrastructure.
Due to the built-in redundancy of our network architecture, we do not anticipate any disruption to customer services during this maintenance window.
Should you have any questions or require further assistance, please contact our Support Team by submitting a ticket via the support portal.
We appreciate your understanding and cooperation.
Best regards, ServLogi Support Team
Posted Mar 26, 2025 - 21:27 UTC
This scheduled maintenance affected: Regions (NYC1).